Prestashop 1.7 Os lo contamos todo

Prestashop 1.7 Os lo contamos todo

Estos días ha irrumpido en nuestras vidas Prestashop 1.7, la nueva versión de nuestra aplicación para la creación de tiendas virtuales favorita. Nos hemos puesto manos a la obra y ya tenemos nuestras primeras conclusiones. Vamos con ello:

Arquitectura Prestashop

Uno de los cambios más importantes de esta versión es sin duda alguna la nueva arquitectura, la anterior ya ha superado su tiempo de vida.

La versión 1.5, fue una versión significativa que introdujo muchos cambios en la revisión del código base heredado de la versión 1.4. La introducción de la función multitienda, la función avanzada de gestión de stock, la revisión de la API modulo y la refactorización general del núcleo, con el fin seguir las mejores prácticas MVC.

Prestashop 1.6 mantuvo la mayor parte de la arquitectura 1.5 intacta. El backend y frontend totalmente rediseñados utilizando Bootstrap, de esta forma consiguieron que tanto el front como el back fuesen responsive. Otras importantes funcionalidades fueron rediseñadas, pero el código base siguió siendo por un largo tiempo el mismo incorporado en la versión 1.5, permitiendo a la comunidad, desarrolladores y vendedores mantener la compatibilidad de sus temas y módulos.

Como podemos ver la arquitectura 1.6, fue heredada de la versión 1.5, por lo que ya se notaba su edad en el desarrollo.

La idea detrás de la nueva arquitectura de Prestashop 1.7, es que el código sea mucho más robusto, modular y que permita realizar test unitarios. La elección de Symfony es bastante clara, dado que representa el nuevo estándar de PHP.

Por supuesto que habían otros frameworks populares en los que podían basar su desarrollo, sin embargo ninguno de ellos ha conseguido en términos de calidad de código y popularidad, la fama que tiene Symfony.

Prestashop 1.7

Backoffice simplificado

UX tiene un papel muy importante en esta nueva versión y lo notamos en el rediseño de esta nueva interfaz. La estructura que tiene es mucho más simple y atractiva, dividiendo todas las funcionalidades en tres grandes bloques: Sell, Improve y Configure… básicamente lo que necesitamos: vender, mejorar y configurar.

Anteriormente había muchas opciones de configuración que estaban un poco escondidas, submenús que llevaban a las diferentes opciones de configuración. Han priorizado la creación de productos, para que sea una de las tareas más sencillas de llevar acabo, pasando del antiguo menú lateral a unas pestañas superiores que aprovechan mejor el espacio y mejoran la experiencia de usuario.

Nuevo sistema frontend y diseño

La nueva plantilla Starter Theme es asombrosa, los cambios a nivel de UI/UX son importantes, ha sido estructurada y diseñada para facilitar la vida a los desarrolladores y diseñadores, permitiéndoles dar rienda suelta a su creatividad de manera mucho más fácil.

La directriz principal que han seguido para diseñar el tema por defecto es que deba ser fácilmente adaptable a cualquier tipo de productos que se vendan en la web, para ello eligieron un estilo visual light que mejora la experiencia de usuario y permite convertir los productos en las verdaderas estrellas de la tienda.

El proceso de compra en 5 pasos ha sido eliminado, consiguiendo que un sola página el usuario sea capaz de rellenar rápidamente toda la información relevante.

El nuevo tema utiliza por defecto el nuevo framework Bootstrap 4 y utiliza SASS en asociación con Bourbon para generar todos los estilos CSS. Bourbon facilita la vida de los desarrolladores proporcionándoles helpers que generan automáticamente todos los prefixes que necesitan los navegadores para mantener la compatibilidad.

También sabemos que utiliza la versión de jQuery 2.2 junto con el compilador Babel para generar el código JavaScript, asegurando la compatibilidad JS entre navegadores y asegurando el cumplimiento del estándar ES2015 (EcmaScript 6).

Child themes

El concepto de child themes, ya lo hemos visto en otros CMS tan conocidos como Wordpres, nos permitirán modificar las plantillas sin temor a perder los cambios, al realizar actualizaciones.

Compatibilidad con 1.6

Lamentablemente la nueva versión de prestashop no es compatible con la versión 1.6, por lo que no se podrán realizar actualizaciones “fácilmente” desde la versión 1.5 o 1.6 a la versión 1.7

 

Desde nuestro punto de vista Prestashop 1.7 sigue siendo una gran candidata para cualquier ecommerce que se quiera desarrollar, nosotros la defendemos como nuestra plataforma prioritaria para este tipo de desarrollos, siempre y cuando empecemos los proyectos desde cero, no recomendamos el upgrade desde Prestashop 1.6. Ahora con esta nueva arquitectura estamos seguros que seguiremos disfrutando aun mas con estos desarrollos.

2 Comentarios

  1. Hola. Estoy planteándome actualizar mi prestashop 1.5. Y ya puestos me gustaría que fuera a esta última versión. Si pongo un tema nuevo compatible (me olvido de momento de los módulos que tengo), ¿se puede instalar la 1.7 como si fuese desde cero pero usando mi actual la base de datos? Si es posible supongo que habría que hacer cambios en esa base. ¿Podéis comentar algo?

    Responder
    • ¡Hola!

      ¿se puede instalar la 1.7 como si fuese desde cero pero usando mi actual la base de datos?

      Por poder se puede “instalar”, en este caso se trataría mas bien de una actualización, pero es muy probable que la gran mayoría de módulos que tengas instalados en la versión 1.5 dejen de funcionar. Ten en cuenta que han realizado un cambio de arquitectura importante y no mantienen la compatibilidad con legacy code como pasaba con la transición entre 1.5 y 1.6, es por ello que nosotros recomendamos mejor actualizar primero a la versión 1.6 en su ultima release mas estable. Hacer una actualización a 1.7 directamente lleva muchísimo trabajo a nivel de programación/maquetacion y base de datos, no creemos que te compense y es muy probable que falle.

      También recomendamos hacer todo el proceso de forma local en un entorno de desarrollo (xampp/wamp/etc) por todo el trabajo que conlleva, hacerlo directamente en producción puede provocar fallos catastróficos, es muy importante que hagas la transición de una versión a otra de forma ordenada, como te comentábamos primero una actualización a la versión 1.6 y posteriormente a 1.7 y por supuesto guardando copias de seguridad en cada paso que das.

      Si después quieres usar un tema nuevo compatible con la versión 1.7, también necesitaras que los módulos sean compatibles con esta versión.

      Un saludo

      Responder

Enviar comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *